"Series AI" and "AI" buttons failing to appear in XVWeb
Behavior:
The following buttons do not appear when viewing a series within XVWeb, preventing the AI function from being usable:
Causes:
- The Location drop-down is set to a location that does not have the AI integration enabled, or does not have Show AI enabled
- The Location drop-down is set to a location that does not have the modality enabled that is being viewed
- AI integration is not yet enabled for your practice's location
- AI integration is not yet enabled for your XVWeb site
Solutions:
- Verify the modality of the series/images being viewed is a modality supported by the AI vendor - typically IO or PX. Unsupported modalities will not allow the AI buttons to appear.
- Ensure the Location drop-down is set to the correct, AI enabled location. The drop-down is located in the top-right corner, to the left of your username:
- If the Location drop-down is set to the correct location and the series being viewed is of a supported modality (typically IO or PX), but the Series AI and AI buttons still fail to appear, please submit a ticket so our support team can investigate further.
AI results not appearing on recently captured images
Behavior:
After a series of images is captured and forwarded to XVWeb, AI results are not visible on the newly captured images, but AI results can be displayed on previously captured images.
Causes:
- the AI request is in a Pending state
- The AI did not detect any potential pathologies within the image(s)
- The Capture Station where the series of images was captured is unmapped, or is mapped to a location that does not have AI enabled
- The Location drop-down is set to a location that does not have the modality enabled that is being viewed, or is set to a location that does not have AI enabled
Solutions:
- To determine if the AI request is in a Pending state, click on an image in the recently captured series, then click the button labeled "AI." The status of the AI request will be shown. Once the results have been received by us from the vendor, AI pathologies will become visible.
-
Example of a Pending request, where AI results are not yet available:
-
Example of a completed request, where AI results are available:
-
Example of a Pending request, where AI results are not yet available:
- Verify the modality of the series/images being viewed is a modality supported by the AI vendor - typically IO or PX. Unsupported modalities will not allow for AI results to be requested from the vendor.
- Verify the Capture Station where the recently captured images were taken is mapped to the correct, AI enabled location - see Managing Capture Stations to confirm the Capture Station is mapped, and map it to the correct location if not already.
- If you find AI results are still not visible after confirming the Capture Station is properly mapped and the series being viewed is of a supported modality (typically IO or PX), or if you find an AI request has been stuck on Pending for an extended period of time, please submit a ticket so our support team can investigate further.
AI results not appearing on historical images
For practices integrating AI with PMS: If your AI Vendor integrates with your Practice Management Software, you'll need a 12- or 18-month historical image extract. This is usually included when AI is enabled for your site and can take weeks, so confirm the ETA with your AI Vendor. For older images, view the series in XVWeb to request AI analysis.
For practices not integrating AI with PMS: If you're using AI Overlay features in XVWeb without PMS integration, then a historical extract is not included in that process, so AI results are only expected to appear on images captured after AI was enabled. For AI analysis on images older than the date your location went live with AI, view the series in XVWeb to request AI analysis.
Behavior:
When viewing converted images, or images acquired prior to the enablement of AI, AI results are not visible.
Causes:
- the AI request is in a Pending state - AI requests on historical images (image taken prior to the enablement of AI) take a longer time to process, and AI requests are not sent to the vendor until a historical series is viewed.
- The AI did not detect any potential pathologies within the image(s)
- The Capture Station where the series of images was captured is unmapped, or is mapped to a location that does not have AI enabled
- The Location drop-down is set to a location that does not have the modality enabled that is being viewed, or is set to a location that does not have AI enabled
Solutions:
- To determine if the AI request is in a Pending state, click on an image in the recently captured series, then click the button labeled "AI." The status of the AI request will be shown. Once the results have been received by us from the vendor, AI pathologies will become visible.
-
Example of a Pending request, where AI results are not yet available:
-
Example of a Pending request, where AI results are not yet available:
- Verify the modality of the series/images being viewed is a modality supported by the AI vendor - typically IO or PX. Unsupported modalities will not allow for AI results to be requested from the vendor.
- Verify the Capture Station where the historical images were taken or converted from is mapped to the correct, AI enabled location - see Managing Capture Stations to confirm the Capture Station is mapped, and map it to the correct location if not already.
- If you find AI results are still not visible after confirming the Capture Station is properly mapped and the series being viewed is of a supported modality (typically IO or PX), or if you find an AI request has been stuck on Pending for an extended period of time, please submit a ticket so our support team can investigate further.
Certain pathologies unavailable when reviewing AI results
Behavior:
When reviewing AI results on a particular image or series, not all pathologies are displayed. For example, Caries are an available pathology on one image, but are not available on a different image.
Cause:
When AI results are returned to XVWeb by the AI vendor, only detected pathologies will display and appear as a selectable option when clicking the "AI" button.
- Example of an image where the only detected pathology was "Measurements:"
- Example of an image where both "Measurements" and "Caries" were detected. Note that "Caries" does not appear as an option in the previous example, as no potential Caries were detected:
Selected AI pathologies are not remembered between series, location specified in the Location drop-down does not save
Behaviors:
- When viewing an image in XVWeb, then navigating to the AI menu by clicking the image > clicking the AI button, the pathologies selected are not checked/enabled by default upon viewing a different series of images. This causes the user to have to select the pathologies they'd like to view every time a different series is viewed.
- Additionally, the location specified in the Location drop-down fails to save, causing the user to have to manually select the correct location each time XVWeb is opened.
Cause:
- Both of the above behaviors are directly caused by the browser's inability to store cookies. The remembered AI pathologies as well as the location specified in the Location drop-down are stored in the cookies that are produced by XVWeb - if the browser is running in a way that prevents cookie storage, this issue will be seen.
Solution:
- Ensure your preferred/default browser is allowed to store cookies and other site data, and is not running in Guest Mode, under a guest profile, or otherwise configured in a way that causes cookies to be rejected or removed every time the browser is closed.
Browser settings and configurations are not directly supported by or managed by Planet DDS, and would require the practice's local IT provider to reconfigure the browser in a way that allows for cookies and other site data to be stored moving forward.