The following error regarding deleted/merged patient is display in XrayVision™(XV):
CAUSES
- This error message is typically displayed when working with a particular patient record that is either deleted or merged by an XrayVision user on another networked workstation. The XrayVision user that is either deleting or merging patient records is presented with a warning message indicating that the patient record is being accessed by a particular computer but has the option to proceed with the action. If they choose to do so, the computer with the opened patient record will display the Patient Deletion Warning above.
- Network connectivity loss interferes with XV's ability to check the status of open patients with the patient database. Depending on when the network connectivity is lost, XV can sometimes be fooled by the operating system into believing that the indicated patient has been removed from the patient database and therefore generate the 'Patient Deletion Warning' above rather than a 'Network Error' message.
Warning: In these situation's DO NOT click the OK button if in the middle of an image capture because the application may crash and images temporarily stored in Windows Temp files may be lost. Follow the steps below before clicking on the OK button.
RESOLUTION
If running an older version of XrayVision, Apteryx recommends upgrading to the latest version for improved error handling.
XrayVision will be unable to save to a particular patient record if it no longer exists. Follow the steps below If a new image or layout/series was created:
Warning: Steps below must be performed BEFORE clicking on the OK button on the 'Patient Deletion Warning' dialog box if the error is caused by loss of network connectivity.
- Saving a Layout
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On the same computer on which the error message is displayed, select Start > Programs > Windows Explorer.
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Using Windows Explorer, navigate to your temporary directory (usually C:\Windows\Temp).
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Double click on the /XVAWorkInProgress/ subdirectory.
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Drag all of the subdirectories to a temporary location (usually your desktop).(Do not leave them in the /XVAWorkInProgress/ directory for they will automatically be deleted.)
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Click on the OK button, close down XV and reboot the computer.
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Once the computer has rebooted, restart the XV application.
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Perform the following steps for each of the subdirectories that were copied/moved out of the /XVAWorkInProgress/ directory:
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Select File > Acquire > Capture Layout Images from the menu.
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Select any style of layout (it will be replaced shortly).
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Select Group > Display As > Grid View from the menu.
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Drag-and-drop the files contained in the subdirectory onto one of the cells in the grid within XV.
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Select Group > Display As > Layout View from menu.
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Select Group > Layout Options > Associate Layout the menu.
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Select the appropriate layout that should be used with these images.
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Select File > Save from the menu.
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Delete the directories that were copied/moved out of the /XVAWorkInProgress/ subdirectory.
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- Saving a Single Image
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Go to one of the other image capture workstations on the network.
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Start the XV application.
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Open the patient for whom the warning message is displayed on the other computer.
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Select File > Open from menu. Click on the Open File Direct button. The 'Open' dialog box displays.
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Select the server on which the XVa3 application is installed.
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Navigate to the main XV application directory on your server.
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Double-click on the /SafetyCache/ subdirectory.
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Double-click on the subdirectory named after the computer on which you received the warning message.
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Select all of the files listed.
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Click on the Open button.
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The 'Move Files To Patient' dialog box displays.
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Enable the On successful move, delete original file option.
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Click on the Yes, add these files to the patient button.
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The 'Extended Image Information dialog box displays. Associate the appropriate 'Image Type', 'Image Subtype', and then click on Done.
- Go back to the computer displaying the warning message, close XV and reboot the computer.
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Article Version 1.0 2019.11.1